Quoting Capabilities Currently Down - Dashboard, Quote Flow and API

Incident Report for Coterie Insurance

Resolved

The issue has been resolved and all systems are operational.
Posted Mar 10, 2026 - 17:37 EDT

Investigating

We are currently experiencing issues while trying to quote on our Dashboard, Quote Flow and API platforms. We are actively investigating.
Posted Mar 10, 2026 - 17:07 EDT
This incident affected: Coterie APIs, Agent Dashboard, and Quote Flow.